Error Ubuntu al pasar de V1 a V2

Responder
gabriel.martinez
Mensajes: 13
Registered for: 3 years 3 months
Spain

Error Ubuntu al pasar de V1 a V2

Mensaje por gabriel.martinez »

Buenas tardes, he estado usando la versión V1 de Mod-Harbour sin problemas, tanto en entorno windows, como en un servidor virtual en la nube con sistema Linux.
He adaptado mis aplicaciones a la versión V2 y funcionan bien en windows, pero en las pruebas que estoy realizando en Ubuntu 18.04, me aparece este mensaje en el error.log de apache2.
[Mon Dec 04 19:02:03.652573 2023] [mpm_event:notice] [pid 51:tid 140417786973120] AH00489: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[Mon Dec 04 19:02:03.662541 2023] [core:notice] [pid 51:tid 140417786973120] AH00094: Command line: '/usr/sbin/apache2'
[Mon Dec 04 19:02:03.686594 2023] [:notice] [pid 54:tid 140417786973120] MH_MESSAGE: Using MH_LIBRARY: /var/www/html/libmhapache.so
[Mon Dec 04 19:02:03.686735 2023] [:notice] [pid 54:tid 140417786973120] MH_MESSAGE: Using MH_NVMS: 10
[Mon Dec 04 19:02:04.689566 2023] [:crit] [pid 54:tid 140417786973120] MH_MESSAGE: dlopen error: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /tmp/libmhapache0.so)
He buscado en Internet y las soluciones pasan por actualizar a la versión de Ubuntu 20.04, si no he entendido mal.
El problema es que el servidor virtual tiene la versión 18.04 y al estar en producción no me atrevo a realizar el cambio de sistema (tampoco estoy seguro de poder hacerlo, puesto que el servidor virtual tiene la versión Ubuntu 18.04 por defecto).
Por eso os consulto si sabéis cómo solucionar el error y cómo puedo instalar GLIBC_2.29 que es lo que parece que no existe en el servidor.
Gracias.

diegof
Mensajes: 42
Registered for: 2 years 10 months
Argentina

Mensaje por diegof »

Tienes que construir v2.1 con ubuntu 18.04. o sino descargar glibc 2.29 y contruirlo. De estas dos opciones te recomiendo la primera.
gabriel.martinez escribió: Lun Dic 04, 2023 7:23 pm Buenas tardes, he estado usando la versión V1 de Mod-Harbour sin problemas, tanto en entorno windows, como en un servidor virtual en la nube con sistema Linux.
He adaptado mis aplicaciones a la versión V2 y funcionan bien en windows, pero en las pruebas que estoy realizando en Ubuntu 18.04, me aparece este mensaje en el error.log de apache2.
[Mon Dec 04 19:02:03.652573 2023] [mpm_event:notice] [pid 51:tid 140417786973120] AH00489: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[Mon Dec 04 19:02:03.662541 2023] [core:notice] [pid 51:tid 140417786973120] AH00094: Command line: '/usr/sbin/apache2'
[Mon Dec 04 19:02:03.686594 2023] [:notice] [pid 54:tid 140417786973120] MH_MESSAGE: Using MH_LIBRARY: /var/www/html/libmhapache.so
[Mon Dec 04 19:02:03.686735 2023] [:notice] [pid 54:tid 140417786973120] MH_MESSAGE: Using MH_NVMS: 10
[Mon Dec 04 19:02:04.689566 2023] [:crit] [pid 54:tid 140417786973120] MH_MESSAGE: dlopen error: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /tmp/libmhapache0.so)
He buscado en Internet y las soluciones pasan por actualizar a la versión de Ubuntu 20.04, si no he entendido mal.
El problema es que el servidor virtual tiene la versión 18.04 y al estar en producción no me atrevo a realizar el cambio de sistema (tampoco estoy seguro de poder hacerlo, puesto que el servidor virtual tiene la versión Ubuntu 18.04 por defecto).
Por eso os consulto si sabéis cómo solucionar el error y cómo puedo instalar GLIBC_2.29 que es lo que parece que no existe en el servidor.
Gracias.

gabriel.martinez
Mensajes: 13
Registered for: 3 years 3 months
Spain

Mensaje por gabriel.martinez »

Muchas gracias, Diego, optaré por construir v2.1 con ubuntu 18.04.
No lo he hecho nunca, así que según vaya tropezando en el camino iré preguntando en el grupo.

Responder